## Overview
GitLab has addressed a critical vulnerability identified as CVE-2026-97229. This flaw affects GitLab Community Edition (CE) and Enterprise Edition (EE) versions 19.2 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2. An unauthenticated user could exploit this vulnerability to execute arbitrary code on the GitLab server through a specially crafted regular expression in a CI/CD configuration.
## Technical Details
The vulnerability stems from insufficient validation of regular expressions. Under certain conditions, an attacker can manipulate the CI/CD configuration to introduce malicious code. This flaw has a CVSS score of 10.0, indicating a critical severity level. The weaponization of this exploit means that it is now publicly available, increasing the urgency for organizations to act.
## Impact
If exploited, this vulnerability could allow attackers to gain full control over the GitLab server. This could lead to unauthorized access to sensitive data, disruption of services, and potential lateral movement within the network. Organizations using affected versions of GitLab are at significant risk and should prioritize remediation.
## Mitigation
Defenders must update their GitLab installations to the latest patched versions immediately. The fixed versions are 19.2.8, 19.3.5, and 19.4.2 or later. Additionally, organizations should review their CI/CD configurations for any suspicious changes and monitor for unusual activity on their GitLab servers. Regular expression validation should also be reinforced as part of the security best practices.
CSURFACE Threat Sensor